Howto add Qt support for geordi

Install Qt to geordi rt:

./configure -prefix /path/to/geordi/rt/usr/local/Trolltech/Qt-4.3.3
make
make install

Remove from compile-config:

-pedantic-errors

Add to compile-config:

-D_REENTRANT -DQT_SHARED -DQT_CORE_LIB
-I/usr/local/Trolltech/Qt-4.3.3/include
-I/usr/local/Trolltech/Qt-4.3.3/include/QtCore
-L/usr/local/Trolltech/Qt-4.3.3/lib -lQtCore
-lpthread -ldl

Add to prelude/prelude.h:

#include <QtCore/QtCore>
#include </usr/local/Trolltech/Qt-4.3.3/mkspecs/linux-g++/qplatformdefs.h>

Leave a Reply